Windows 98 Class -- Hands On Exercises

1. Use Windows Help to browse the Introducing Windows 98 Section

2. .Prepare a new hard disk for Windows 98 installation 

3. Test Windows 98 Setup program, discover Windows 98 Setup switches

4. Discover Windows 98 Startup Menu and boot options

5. Using a Windows 98 Peer Network

6. Installing a Windows 98 Peer Network 

7. Windows 98 Post-Installation tips

Exercise 1 What's new in Windows 98:

Press F1 or click Start->Help.  Go to Contents page and double-click Introducing Windows 98

Windows 98 makes your computer easier to use, with new and enhanced features.

Web integration
Multiple display support
Power management
Universal Serial Bus
Accessibility wizard
Help
Read "If you're upgrading from Windows 3.1"

Browse Windows 98 Resource Kit help file.  Open Windows Explorer to \WIN98\RESKIT\HELP.  Double-click on RK98BOOK.CHM.

Exercise 2: Preparing a new hard disk for Windows 95/98 installation

If you have a new hard disk purchased separately from your computer, it must be partitioned before you can install Windows 95/98.  To partition a hard disk you need 

a) a bootable version of the Windows 98 Second Edition CD-ROM or 

b) a floppy boot disk formatted with some version of the MS-DOS operating system.  

If you have a copy of Windows 98 Second Edition on a bootable CD and a computer that supports booting from the CD-ROM drive, you can just insert this CD, turn on the computer, and it will run, giving you the options of 1) accessing a DOS command prompt and installing Windows 98 on a formatted hard drive.  2) formatting and partitioning a new hard drive from scratch, automatically installing the Windows 98 operating system.

Generally, you won't want a version dated previously to 8/24/1996 when Microsoft added support for large FAT32 disk partitions to Windows 95.  (Before this point, the largest size permissable for a DOS/Windows disk partition was 2 Gigabytes.)
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If you have Windows 95 (or better than that, Windows 98) installed on another computer, the easiest way to obtain a system boot disk is to create one from the version of Windows installed on the other computer.  (Open the Control Panel, choose Add/Remove Programs, go to the Startup Disk tab and click the Create Disk button.)

If you want to install Windows 95/98 on a hard disk that already contains a bootable c-drive (or reinstall over an existing version), then boot the computer from your floppy Windows Startup Disk, (if you created the startup disk in Windows 98, choose "Load CD-ROM support, when prompted).  Then insert your Windows CD, log on to your CD-ROM drive and enter the command SETUP.  If you are using a "For a New PC copy of Windows 98, then format the hard disk first:

FORMAT C: 

Using FDISK to partition a hard disk

For a new hard disk, or to create brand new partitions on an existing hard disk, you must use the DOS FDISK utility.  After booting to a DOS prompt (A:\> or C:\> with an emergency startup disk.

1. Enter FDISK at the command prompt.

2. If this version of DOS supports FAT32, you will see an initial screen prompt asking whether to enable large disk support.  If you want to install Windows on a FAT16 partition, (compatible with Windows NT 4.0 and some other operating systems) answer No.  If you want to install Windows on a FAT32 partition (with a single c-drive as large as your hard disk, better Windows 98 performance, but no ability to dual-boot Windows NT 4), answer Yes.
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3. On the next screen, to create a new bootable c-drive on your computer, choose option 1, Create DOS Partition or Logical Drive.  then choose option 1 again on the next screen, Create Primary DOS partition
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4. If Windows 98 will be the only operating system on the disk, allow FDISK to create a c-drive on the next screen that uses all available space on the drive.  If you intend to install Windows NT or another operating system on the disk later, then limit the amount of space reserved for Drive C.  (If you have a 6.4GB disk, for instance, and want to dual-boot Windows NT you might create 2GB partition for drive C and allow Windows NT to use the rest of the drive, later on, to install itself.  Remember that drive C must be FAT16 rather than FAT32 for you to do this.)
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5. FDISK will prepare the hard drive and prompt you to reboot the computer.  Before quitting the program, press Esc until you're back at the first Options menu.  Choose Option 2, Set active partition and then, on the next screen, enter 1 to activate the C-drive you've created.
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6. Now exit FDISK and reboot the computer from your Win98 CD or floppy startup disk. (If you boot from the Windows CD, choose the option to boot to a command prompt. From either CD or floppy, choose the option to load CD-ROM support.

7. When the computer reboots to a command prompt, issue the following command:
FORMAT C: /S.

Your C-drive is now bootable and ready for the Windows installation.  Log onto the drive letter of your CD-ROM and enter the command SETUP..

Exercise 3- Discover the Windows 98 Setup switches

Click Start->Run and enter \WIN98\SETUP /?  Click OK after reading the options screen.

Also read these Microsoft Knowledge Base articles to learn
everything about the "official" SETUP switches:
1. "Windows 95 Setup Switches":
http://support.microsoft.com/support/kb/articles/Q128/4/00.asp
and:
2. "Description of the Windows 98 Setup Switches":
http://support.microsoft.com/support/kb/articles/Q186/1/11.asp
Exercise 4 -- Discover Windows 98 Startup Menu and Boot options

1. Boot to the Windows 98 Startup Menu. Shut down Windows if currently running and choose "Shut Down Windows" from the Shutdown menu.  Turn the computer back on. When the system reboots, hold down the CTRL key before the "Starting Windows 98" message appears on the screen.

2. Choose MS-DOS Command Prompt from the Startup Options.  Switch off the computer after you reach the C-prompt, hold down the CTRL key and reboot into the Startup Menu.  This time, choose Step-by-step boot.

3. After Windows 98 reappears, open My Computer.  Choose View->Folder Options->View and click "Show All Files" in the Hidden Files section.

4. In Windows Explorer or My Computer, go to the C:\ directory, select MSDOS.SYS, right-click and open its file properties. Deselect or confirm that the "read only" and "hidden file" options are deselected. 

5. Open Notepad.  Choose File->Open, select "All Files" in the "Files of All Types" field and open MSDOS.SYS.   Examine the various default settings.  Under [Options] change the BOOTGUI= setting from '1' to '0' and save the file.

6. Shut down Windows 98 and restart.  What happens?  Does the Windows interface load?

From the C-prompt, enter EDIT to open the MS-DOS Editor.  Open the MSDOS.SYS configuration file and restore the default setting of "BOOTGUI=1"

This table describes all of the entries in MSDOS.SYS, with their typical default values.

Production:  Note that the following table contains indented items and special characters.

Entry
Description

[Paths] section:


HostWinBootDrv=c
Defines the location of the boot drive root directory.

WinBootDir=
Defines the location of the necessary startup files. The default is the directory specified during Setup; for example, C:\Windows.

WinDir=
Defines the location of the Windows 98 directory as specified during Setup.

UninstallDir=
Defines the location of the directory used for uninstall data, to return the computer to a previous operating system

[Options] section:


Autoscan=
Controls the automatic launching of ScanDisk after a bad Windows 98 shutdown.  AutoScan=0 disables the running of ScanDisk, AutoScan=1, the default, causes the system to prompt you to run ScanDisk after a bad shutdown.  AutoScan=2 bypasses system prompts and runs ScanDisk automatically.

BootDelay=n
Sets the initial startup delay to n seconds. The default is 2. BootKeys=0 disables the delay. The only purpose of the delay is to give the user sufficient time to press F8 after the Starting Windows message appears.

BootFailSafe= 
Enables Safe Mode for system startup. The default is 0. (This setting is enabled typically by equipment manufacturers for installation.)

BootGUI=
Enables automatic graphical startup into Windows 95. The default is 1.

BootKeys=
Enables the startup option keys (that is, CTRL, F5, F6, and F8). The default is 1. Setting this value to 0 overrides the value of BootDelay=n and prevents any startup keys from functioning. This setting allows system administrators to configure more secure systems

BootMenu=
Enables automatic display of the Windows 98 Startup menu, so that the user must press F8 to see the menu. The default is 0. Setting this value to 1 eliminates the need to press F8 to see the menu. 

BootMenuDefault=#
Sets the default menu item on the Windows Startup menu; the default is 3 for a computer with no networking components, and 4 for a networked computer.

BootMenuDelay=#
Sets the number of seconds to display the Windows Startup menu before running the default menu item. The default is 30.

BootMulti=
Enables dual boot capabilities. The default is 0. Setting this value to 1 enables the ability to start DOS by pressing F4 or by pressing F8 to use the Windows Startup menu.

BootWarn=
Enables the Safe Mode startup warning. The default is 1.

BootWin=
Enables Windows 95 as the default operating system. Setting this value to 0 disables Windows 95 as the default; this is useful only with DOS version 5 or 6.x on the computer. The default is 1.

DblSpace=
Enables automatic loading of Dblspace.bin. The default is 1.

DoubleBuffer=
Enables loading of a double-buffering driver for a SCSI controller. The default is 0. Setting this value to 1 enables double-buffering, if required by the SCSI controller.

DrvSpace=
Enables automatic loading of Drvspace.bin. The default is 1.

LoadTop=
Enables loading of Command.com or Drvspace.bin at the top of 640K memory. The default is 1. Set this value to 0 with Novell® NetWare® or any software that makes assumptions about what is used in specific memory areas.

Logo=
Enables display of the animated logo. The default is 1. Setting this value to 0 also avoids hooking a variety of interrupts that can create incompatibilities with certain memory managers from other vendors.

Network=
Enables Safe Mode With Networking as a menu option. The default is 1 for computers with networking installed. This value should be 0 if network software components are not installed. 

Winver=
Designates the version and build number of the Windows operating system installed on the host drive.

Exercise 5 -- Using the Network

Instructor demonstrates network architecture:  network adapter, cable, hub

10base T and 10base 2

Network Exercises

1. Open Network Neighborhood

browse computers, identify icons (workgroup, entire network.

2. Read Access: Connect to shared My Documents Folder on instructor computer.  Open File.
Copy file from shared My Documents folder to local hard disk.
Open file in My Documents through application.  Attempt to save it to network folder (will fail)
Write access: Students create document with their own name on their desktops and copy to shared folder on Instructor computer.

3. Students examine Network Neighborhood and verify that File and Printer Sharing is installed on their local computers.  (If already installed, may remove and reboot.)

4. Students partner up.  Each creates a shared folder on the desktop. with password protected full access.
a) each student creates a document within their own folder with their own name and signs it.
b) each student accesses the document on their partner's computer and signs in, resaving the document.

5. Connecting to a shared printer:  each student connects to the shared Printer on the Instructor's workstation.  Attempt to print document.

6. Creating a shared printer:  each student creates a shared printer on their own workstation.

Exercise 6 Network Setup

Examine NN, (right-click, properties).  Observe basic components.  

Instructor demonstrates client and protocol settings.  (TCP/IP)

There are three basic login types.  (Instructor demonstrates.).  Identification tab shows workgroup and computer name.  Access tab toggles share-level and user-level access.

Students go to side computers, remove network configuration and reinstall.  Observe procedures for testing physical network and software configuration.

 NETWORK LAB

1. Right-click Network Neighborhood – observe components

2. Close Network Neighborhood, right-click My Computer and open its Properties

3. Select TCP/IP protocl and open its Properties

4. Copy down the following information about the TCP/IP configuration:

Your computer’s assigned IP address and subnet mask (mine are 130.212.8.67
                                                                                                   and 255.255.255.0)

The SFSU Gateway address (130.212.8.254)

The SFSU Domain Name Server configuration:

Host: Yourcomputer                   Domain:  sfsu.edu

DNS Server Search Order:


130.212.10.163

       130.212.10.162

You’ll need this information later on, when you rebuild the network configuration for your computer.

5. Go to the Device Manager tab and expand the Network section

6. Observe the listing for the NIC, highlight it and choose remove.

7. Shut down the computer.

The computer is now in roughly the state that it would be in if you were installing a network card for the first time.  We’re going to skip the actual insertion of hardware

1. Turn on the computer.  In most cases, Win95/98 plug and play will automatically detect the network card.

2. Windows may ask you to insert a driver disk or automatically install a driver for the network card.  You will be prompted to reboot the computer.

3. Before rebooting, right-click Network Neighborhood, open its properties and inspect the Components list.

Exercise 7 Post Installation tips

1. Adjust Display Resolution.  Right-click the Desktop, select Properties.  Click the Settings tab.  Move the slider to 640x480 and click OK.  After the display readjusts itself, open the Display Properties again, and readjust the display to 800x600.  Click the Advanced Tab under Settings and checkmark "Show settings icon on Taskbar."  When the icon appears in the System Tray portion of the taskbar, click on it, and notice the express shortcut for changing screen resolutions.

2. Add useful programs omitted during Setup.  Open Control Panel->Add/Remove Programs and click on the Windows Setup tab.

3. Hardware Integrity Check  Right-click My Computer icon, choose Properties and click on the Device Manager tab.
4. Create Quick Access Shortcuts  (Start Menu and Desktop)
5. Verify installation/install modem and printer

6. Optimize Windows Performance Settings:  System Applet, Multimedia applet
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